14 Aprile 2019

ILoveTech - Il magazine per tutti gli amanti della tecnologia

Come fare le somme con Excel? Le formule da usare

Come fare le somme con Excel? Le formule da usare

Scritto da Giorgia Fanari

- 5 Febbraio 2018

Per realizzare dei file su Excel in grado di sommare dati nello stesso foglio o in fogli diversi: ecco una guida per scoprire come fare le somme con Excel.

Dovete sistemare i conti di casa oppure organizzare i dati del lavoro ma non sapete come fare le somme con Excel? In questo articolo vi aiuteremo ad utilizzare le formule per capire come sommare dei dati presenti in una riga di Excel, ma anche in una colonna. E per chi ha bisogno di qualche informazione in più: vedremo anche come sommare i valori presenti in due o più fogli di un documento Excel.

NB: Le informazioni e gli screenshot utilizzati di seguito si basano sui file Excel che possono essere realizzati tramite Google Drive.

Come fare le somme con Excel su una riga

Per sommare su Excel i valori presenti su una riga del file dovete inserire la funziona SOMMA.

Immaginate ad esempio di dover sommare le spese fatte nel mese di Gennaio da 4 persone: selezionate la cella in cui volete che appaia la somma, quindi andate con il cursore su altro, sul simbolo della Sigma (Σ) e quindi sull’opzione “SOMMA”.

Selezionate quindi con il cursore le celle che volete vengano sommate, tenendole selezionate con SHIFT. Potete anche inserire manualmente la formula in questo modo scrivendo all’interno della cella:

= SOMMA(B2:E2)

Tra parentesi andranno inserite la cella da cui volete far partire il calcolo (in questo caso B2) i “due punti” (:) che indicano ad Excel di sommare fino alla cella che inserirete dopo questo simbolo, in questo caso E2. Così, la somma sarà fatta tra i valori presenti in B2, C2, D2 ed E2.

Se invece siete interessati ad avere una somma parziale di alcuni valori presenti sulla stessa riga dovrete utilizzare sempre la formula SOMMA e selezionare con il cursore le celle non adiacenti tenendo premuto CTRL (o nel Mac il tasto cmd). Se volete scriverla manualmente ricordate semplicemente che invece dei “due punti” (:) dovrete inserire “punto e virgola” (;).
Vediamo un esempio: volete calcolare il totale delle spese di Gennaio di Persona 1 e Persona 4. Inserite quindi:

= SOMMA(B2;E2)

Per inserire la stessa formula anche nelle celle sottostanti non dovrete far altro che andare con il cursore sull’angolo in basso a destra della cella contenente la formula: quando apparirà una crocetta cliccate con il tasto sinistro e tenendo premuto trascinate verso il basso. Rilasciate e vedrete che la formula si sarà automaticamente copiata ma ovviamente cambiando i riferimenti.
Alla cella F3 avrete quindi non = SOMMA(B2;E2) ma

= SOMMA(B3:E3)

Come fare le somme con Excel in colonna

A questo punto, avrete bisogno ad esempio di calcolare la somma delle spese sostenute da tutte e 4 le persone nei tre mesi presi in considerazione.

Per avere la somma del trimestre non dovrete far altro che riutilizzare quanto già imparato in precedenza: inserite la formula SOMMA e selezionate le celle che vi interessano (nel caso del nostro esempio F2, F3, F4). Per inserire la formula manualmente scrivete:

= SOMMA(F2:F4)

Potrete applicarla anche alle altre colonne per mettere in evidenza il totale delle spese sostenute da ciascuna persona: oltre ad inserire le formule manualmente, potrete trascinarle come imparato in precedenza.

Come fare le somme con Excel su più fogli

Ipotizzate ora di dover calcolare i totali delle spese sostenute in ogni trimestre e che ogni trimestre sia riportato su un foglio diverso del vostro documento Excel con lo stesso schema che abbiamo costruito negli esempi precedenti.

Nel foglio “riepilogo annuale” vogliamo quindi indicare il totale delle spese fatte da ciascuna persona e il totale generale di tutto l’anno. Qui dovrete fare molta attenzione ad inserire correttamente la formula, basta un minimo errore per non renderla valida.
Per esempio, per calcolare le spese fatte dalla “persona 1” nel corso dell’anno dobbiamo prendere in considerazione le celle B7 di ogni foglio, perché è in quelle celle che abbiamo inserito il totale delle spese trimestrali delle “persona 1”.

Questa la formula che dovrete inserire:

=SOMMA(’1°trimestre’!B7)+SOMMA(’2°trimestre’!B7)+SOMMA(’3° trimestre’!B7)+SOMMA(’4° trimestre’!B7)

Rendendo la formula più generica:

=SOMMA(‘Foglio1’!A1)+SOMMA(‘Foglio2’!A1)+SOMMA(‘Foglio3’!A1)+SOMMA(‘Foglio4’!A1)

Ricordatevi di riportare con esattezza tra le virgolette alte semplici dette anche virgolette inglesi o singoli apici (‘’)il nome del foglio da cui proviene il dato che vi interessa, inserendo eventualmente anche gli spazi presenti nel nome del foglio. Dopo va sempre inserito il punto esclamativo (!) e quindi il riferimento della cella da cui la formula deve prendere il dato.

Potrete quindi replicarla per tutte le persone (cambiando ovviamente il riferimento alla cella) e per il totale dei trimestri.

Tag di questo articolo:

Google